Дата  Запланированые курсы
26.02 DEV-C220. Прикладное программирование с использованием стандартов С++11, 14, 17, 20. Базовый уровень
26.02 DEV-J200. Java EE. Разработка корпоративных приложений
26.02 DEV-C220. Прикладное программирование с использованием стандартов С++11, 14, 17, 20. Базовый уровень (Группа II)
02.03 AutoCAD для интерьеров
02.03 MOC-20761. Создание запросов данных при помощи Transact-SQL
02.03 MOC-20741. Сетевая инфраструктура на основе Windows Server 2016
02.03 QA-QAB. Тестирование программного обеспечения
02.03 DEV-C230. Параллельное программирование на С++ (Стандарт С++11, С++14, С++17, C++20)
03.03 QA-OQA. Оптимизация тестирования программного обеспечения (Группа I)
03.03 QA-OQA. Оптимизация тестирования программного обеспечения (Группа II)
03.03 DEV-J-MP+. Расширенная модульная программа "Разработчик прикладного программного обеспечения (Язык Java)"
03.03 Архитектура современных компьютеров
03.03 DEV-J110. Java SE. Введение в язык Java
04.03 DEV-PY100. Основы процедурного программирования на языке Python
04.03 DEV-PY-MP+. Расширенная модульная программа "Разработчик прикладного программного обеспечения (язык Python)"
04.03 CORTEX-M-MP. Введение в технологии разработки систем управления на базе МК с RISC ядром ARM Cortex-M
04.03 CORTEX-M-INTRO. Введение в современную микроконтроллерную технику
04.03 Основы алгоритмизации и программирования
04.03 DEV-PY-MP. Модульная программа "Разработчик прикладного программного обеспечения (Язык Python)"
06.03 DEV-C-MP+. Расширенная модульная программа «Разработчик прикладного программного обеспечения (Языки С и C++)»
06.03 DEV-C100. Основы процедурного программирования на языках C/C++
12.03 Инструменты бизнес-анализа Microsoft Excel: PowerPivot, PowerView
16.03 DEV-PY100. Основы процедурного программирования на языке Python
16.03 DEV-J110. Java SE. Введение в язык Java
16.03 MOC-20742. Инфраструктура идентификации на основе Windows Server 2016
16.03 MOC-20762. Разработка баз данных SQL
16.03 Поисковая оптимизация (SEO)
16.03 Основы создания веб-сайтов. Adobe Dreamweaver
16.03 DEV-J-MP+. Расширенная модульная программа "Разработчик прикладного программного обеспечения (Язык Java)"
16.03 Adobe After Effects. Создание анимации и эффектов
18.03 CORTEX-M-RISC. RISC-архитектура ARM Cortex-M в микроконтроллерах
18.03 Трёхмерное моделирование. 3ds Max
19.03 Основы создания веб-сайтов. Adobe Dreamweaver
23.03 Автоматизация работы в Excel с использованием VBA
23.03 Средства растровой графики. Adobe Photoshop
23.03 DEV-J120. Java SE. Стандартные пакеты
23.03 Компьютерное проектирование в системе AutoCAD (профессиональный курс)
27.03 DEV-QT10. Прикладное программирование на С++ с использованием Qt. Базовый уровень
30.03 Работа в MS Excel. Расширенные возможности
30.03 Поисковая оптимизация (SEO) для профессионалов
30.03 MOC-20764. Администрирование инфраструктуры баз данных SQL
30.03 Linux-LE. Основы архитектуры и администрирования Linux
30.03 Linux-MP. Модульная программа «Архитектура и администрирование Linux»
30.03 Инструменты бизнес-анализа Microsoft Excel: PowerPivot, PowerView
30.03 DEV-J210. Java EE. Разработка web сервисов
01.04 DEV-J120. Java SE. Стандартные пакеты
02.04 DEV-PY110. Процедурное программирование на языке Python (расширенный курс)
06.04 CCNA-CS. Основы кибербезопасности (CCNA Cybersecurity Operations)
06.04 DEV-J130. Java SE. Разработка многоуровневых приложений
06.04 NET-DLINKSW. Технологии коммутации современных сетей Ethernet
06.04 DEV-PYQT. Разработка оконных приложений Python c использованием Qt
06.04 Средства растровой графики. Adobe Photoshop
06.04 Компьютерное проектирование в системе AutoCAD (базовый курс)
07.04 MOC-20778. Анализ данных в Power BI
08.04 CORTEX-M-STM32F. Семейство МК компании ST Microelectronics STM32Fxxx с вычислительным ядром ARM Cortex M3
13.04 Linux-LF. Расширенное администрирование ОС Linux
13.04 DEV-J200. Java EE. Разработка корпоративных приложений
13.04 Профессиональная верстка сайтов. HTML5 и CSS3
13.04 Веб-дизайн. Создание макетов сайтов
15.04 DEV-C110. Процедурное программирование на языках C/C++
20.04 DEV-PY110. Процедурное программирование на языке Python (расширенный курс)
20.04 DEV-J210. Java EE. Разработка web сервисов
27.04 CS-BASH. Автоматизация задач системного администратора ОС
06.05 DEV-PY111. Базовые алгоритмы и структуры данных на языке Python
11.05 DEV-SWT110. Введение в технологии разработки программного обеспечения: разработка требований и проектирование
13.05 DEV-J130. Java SE. Разработка многоуровневых приложений
14.05 DEV-C200. Объектно-ориентированное программирование на языке С++. Базовый уровень
18.05 CS-LINUX. Обеспечение безопасности ОС Linux
18.05 CS-MPLS. Модульная программа "Обеспечение безопасности серверов и сетей. ОС Linux"
20.05 CORTEX-M-RTOS. Разработка управляющих программ для МК систем управления с использованием многозадачных ОС реального времени
25.05 DEV-PY111. Базовые алгоритмы и структуры данных на языке Python
10.06 DEV-C210. Объектно-ориентированное программирование на языке С++. Углубленное изучение
15.06 DEV-SWT110. Введение в технологии разработки программного обеспечения: разработка требований и проектирование
15.06 DEV-PY200. Объектно-ориентированное программирование на языке Python
22.06 CS-NET. Защита информации в компьютерных сетях
29.06 CS-PT. Тестирование на проникновение (Penetration testing)
02.09 DEV-J200. Java EE. Разработка корпоративных приложений
02.09 DEV-C220. Прикладное программирование с использованием стандартов С++11, 14, 17, 20. Базовый уровень
07.09 DEV-PYWEB. Разработка WEB приложений на языке Python
12.10 DEV-J210. Java EE. Разработка web сервисов
12.10 DEV-QT10. Прикладное программирование на С++ с использованием Qt. Базовый уровень
19.10 DEV-PYQT. Разработка оконных приложений Python c использованием Qt
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

EoMPLS + IPSec
liad
#1 Оставлено : 24 августа 2010 г. 17:17:35(UTC)
Ранг: Активный Участник

Группы: Зарегистрированные пользователи
Зарегистрирован: 04.04.2007(UTC)
Сообщений: 111
Баллов: 333
Откуда: Russia St.-Peterburg

Задача такая соединить два офиса на канальном уровне с шифрованием на третьем уровне. Есть два роутера 3845 и 2851. Вариантов соединения думаю тут два EoMPLS+IPSec или L2TP+IPSec.
Выбрал первое. Пока настраиваю EoMPLS но никак не получается.
Роутер 1
Код:

ip cef
!
interface Tunnel0
ip address 10.10.10.1 255.255.255.252
tunnel source GigabitEthernet0/0
tunnel destination 192.168.100.2
tunnel path-mtu-discovery
!
interface GigabitEthernet0/0
ip address 192.168.100.1 255.255.255.252
duplex auto
speed auto
media-type rj45
mpls ip
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1.19
encapsulation dot1Q 119
xconnect 10.10.10.2 119 encapsulation mpls
!
router ospf 100
log-adjacency-changes
network 10.10.10.0 0.0.0.3 area 0
network 192.168.100.0 0.0.0.3 area 0
!
mpls ldp router-id Tunnel0 force

Роутер 2
Код:

ip cef
!
interface Tunnel0
ip address 10.10.10.2 255.255.255.252
tunnel source GigabitEthernet0/0
tunnel destination 192.168.100.1
tunnel path-mtu-discovery
!
interface GigabitEthernet0/0
ip address 192.168.100.2 255.255.255.252
duplex auto
speed auto
media-type rj45
mpls ip
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1.19
encapsulation dot1Q 219
xconnect 10.10.10.1 119 encapsulation mpls
!
router ospf 100
log-adjacency-changes
network 10.10.10.0 0.0.0.3 area 0
network 192.168.100.0 0.0.0.3 area 0
!
mpls ldp router-id Tunnel0 force


тунель работает, а вот узлы подключенные к интерфейсам g0/1 и напрямую и через коммутатор с настроенными vlan 119 и 219 не пингуются.
Потом планирую crypto map привязать к tunnel0 и g0/0.
Реклама
liad
#2 Оставлено : 25 августа 2010 г. 15:07:42(UTC)
Ранг: Активный Участник

Группы: Зарегистрированные пользователи
Зарегистрирован: 04.04.2007(UTC)
Сообщений: 111
Баллов: 333
Откуда: Russia St.-Peterburg

вывод debug xconnect ...
MPLS peer 10.10.10.1, vcid 119, VC UP, VC state UP
XC L2TP: Failed to find session for peer 10.10.10.1, vcid 119
и аналогично на другом
не понятно почему L2TP?
добавлял pw-class
pseudowire-class myclass
encap mpls
interworking ethernet
xconnect 10.10.10.2 119 encapsulation mpls pwclass myclass
все бесполезно
artmar
#3 Оставлено : 25 августа 2010 г. 22:41:13(UTC)
Ранг: Активный Участник

Группы: Зарегистрированные пользователи
Зарегистрирован: 22.10.2003(UTC)
Сообщений: 330
Баллов: 990
Откуда: Russia СПб

1) Заведите лупбеки с маской /32, положите их в ОСПФ
2) туннели и VC с них пускайте
3) повесьте дизайнера/постановщика задачи :)
EoMPLS+GRE+IPSec - это все равно, что лететь самолетом, который перевозится поездом, а он на пароме :В
4) l2tp через GRE, лучшем случае, удастся положить в IPSEC, но тоже будет криво, как задача
5) Зачем это все?

interface GigabitEthernet0/1.19
encapsulation dot1Q <b>119</b>
xconnect 10.10.10.2 119 encapsulation mpls
!
interface GigabitEthernet0/1.19
encapsulation dot1Q <b>219</b>
xconnect 10.10.10.1 119 encapsulation mpls

свич таги правильные расставляет?


Всего хорошего
liad
#4 Оставлено : 26 августа 2010 г. 12:14:51(UTC)
Ранг: Активный Участник

Группы: Зарегистрированные пользователи
Зарегистрирован: 04.04.2007(UTC)
Сообщений: 111
Баллов: 333
Откуда: Russia St.-Peterburg

спасибо, хотя и поздно уже сделал днем ))),
1) лупбеки и туннель в оспф
2) vc - лупбек - тунель кажется так
3) не понял на счет дизайнера/поставщика задачи
именно так Ethernet - MPLS - GRE - IPSec
4) не думаю что l2tp + ipsec быстрее
5) чтобы соединить два офиса на канальном уровне (несколько vlan'ов)

лупбеки я и до этого делал без ipsec'а, но все это у меня заработало когда поставил два коммутатора с одинаковыми vlan'ами и на роутерах сделал
interface GigabitEthernet0/1.19
encapsulation dot1Q 119
xconnect 10.10.20.2 119 encapsulation mpls
!
interface GigabitEthernet0/1.19
encapsulation dot1Q 119
xconnect 10.10.20.1 119 encapsulation mpls

10.10.20.1 и .2 - лупбеки
в общем то, что нужно.
а задача такая: соединить два офиса на канальном уровне, зашифровав канал
switch1 - роутер1 ----------- выделенная линия ------------- роутер2 - switch2
на свитчах несколько vlan'ов
artmar
#5 Оставлено : 26 августа 2010 г. 14:57:46(UTC)
Ранг: Активный Участник

Группы: Зарегистрированные пользователи
Зарегистрирован: 22.10.2003(UTC)
Сообщений: 330
Баллов: 990
Откуда: Russia СПб

<blockquote id="quote"><font size="1" face="Verdana, Helvetica, Arial" id="quote">quote:<hr height="1" noshade id="quote"><i>Originally posted by liad</i>
на свитчах несколько vlan'ов
<hr height="1" noshade id="quote"></blockquote id="quote"></font id="quote">
тогда настрайвайте VC на физическом интерфейсе, вместо тагированных сабов, а порты свичей настройте в транк :)

Грабли вылезут скорее всего несколько позже, когда вы попытаетесь засунуть VC в IPSEC.


Всего хорошего
Всего хорошего
liad
#6 Оставлено : 26 августа 2010 г. 16:02:23(UTC)
Ранг: Активный Участник

Группы: Зарегистрированные пользователи
Зарегистрирован: 04.04.2007(UTC)
Сообщений: 111
Баллов: 333
Откуда: Russia St.-Peterburg

на свитчах и так транки настроены, а на роутере для каждого влана сделал свой саб и свой vc, т.е.
interface GigabitEthernet0/1.19
encapsulation dot1Q 119
xconnect 10.10.10.2 119 encapsulation mpls
!
interface GigabitEthernet0/1.10
encapsulation dot1Q 100
xconnect 10.10.10.1 100 encapsulation mpls
вроде пока все работает и при том скорость не плохая на 10 мбитном канале файл размером 150 мбайт за 2,5 минуты.
RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Guest
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.