Дата  Запланированые курсы
24.09 Maya (профессиональный курс)
24.09 MOC-20741B. Сетевая инфраструктура на основе Windows Server 2016
24.09 DEV-J30. Программирование на платформе Java. Разработка многоуровневых приложений
25.09 DEV-PY100. Основы процедурного программирования на языке Python
25.09 DEV-PY-MP. Модульная программа "Разработчик прикладного программного обеспечения (Язык Python)"
01.10 Компьютерное проектирование в системе AutoCAD (профессиональный курс)
01.10 Профессиональная верстка сайтов. HTML5 и CSS3
01.10 Компьютерное проектирование в системе AutoCAD (базовый курс)
01.10 MOC-20762. Разработка баз данных SQL
01.10 DEV-С-CP+. Расширенная комплексная программа «Разработчик прикладного программного обеспечения (Языки С и C++)»
01.10 DEV-C10. Процедурное программирование. Языки С/C++
01.10 Основы алгоритмизации и программирования (Группа I)
01.10 Основы алгоритмизации и программирования (Группа II)
02.10 DEV-J-MP+. Расширенная комплексная программа "Разработчик прикладного программного обеспечения (Язык Java)"
02.10 DEV-J10. Программирование на платформе Java. Введение в язык Java
02.10 DEV-J-MP+. Расширенная комплексная программа "Разработчик прикладного программного обеспечения (Язык Java)"
02.10 DEV-J10. Программирование на платформе Java. Введение в язык Java
08.10 MOC-20764. Администрирование инфраструктуры баз данных SQL
08.10 MOC-20742B. Инфраструктура идентификации на основе Windows Server 2016
08.10 DEV-J60. Технологии разработки корпоративных приложений на платформе Java Enterprise Edition (Java EE)
08.10 Введение в тестирование программного обеспечения
15.10 DEV-OCPJP. Подготовка к сдаче сертификационных экзаменов серии Oracle Certified Professional Java Programmer
15.10 Компьютерное проектирование в системе AutoCAD (профессиональный курс)
15.10 Трёхмерное моделирование. 3ds Max
15.10 Работа в MS Excel. Базовый уровень
16.10 DEV-PY101. Базовые алгоритмы и структуры данных на языке Python
17.10 Инструменты бизнес-анализа Microsoft Excel: PowerPivot, PowerView
22.10 MOC-10987. Настройка производительности и оптимизация баз данных SQL
22.10 Введение в тестирование программного обеспечения
22.10 MOC-20744A. Безопасность инфраструктуры средствами Windows Server 2016
22.10 Средства векторной графики. Adobe Illustrator
22.10 Основы создания веб-сайтов. Adobe Dreamweaver
22.10 Работа в MS Excel. Расширенные возможности
24.10 NET-DLINKSW-LAB. Технологии коммутации современных сетей Ethernet. Лабораторный практикум
25.10 DEV-J20. Программирование на платформе Java. Стандартные пакеты
25.10 DEV-J20. Программирование на платформе Java. Стандартные пакеты
29.10 MOC-10961B. Автоматизация администрирования с Windows PowerShell
29.10 Автоматизация работы в Excel 2010 с использованием макросов VBA
07.11 DEV-C20. Объектно-ориентированное программирование. Базовый уровень. Язык С++
12.11 Компьютерное проектирование в системе AutoCAD (базовый курс)
12.11 Профессиональная верстка сайтов. HTML5 и CSS3
13.11 DEV-PY110. Процедурное программирование на языке Python (расширенный курс)
19.11 DEV-J30. Программирование на платформе Java. Разработка многоуровневых приложений
19.11 DEV-J30. Программирование на платформе Java. Разработка многоуровневых приложений
26.11 Средства растровой графики. Adobe Photoshop
26.11 Поисковая оптимизация (SEO)
03.12 Компьютерное проектирование в системе AutoCAD (базовый курс)
03.12 DEV-C21. Объектно-ориентированное программирование. Углубленное изучение. Язык С++
07.12 DEV-PY200. Объектно-ориентированное программирование на языке Python
10.12 Основы создания веб-сайтов. Adobe Dreamweaver
10.12 Средства векторной графики. Adobe Illustrator
10.12 Поисковая оптимизация (SEO) для профессионалов
17.12 Компьютерное проектирование в системе AutoCAD (профессиональный курс)
09.01 DEV-C22. Стандарт С++11, С++14, С++17 для прикладного программирования
14.01 DEV-OCPJP. Подготовка к сдаче сертификационных экзаменов серии Oracle Certified Professional Java Programmer
14.01 DEV-OCPJP. Подготовка к сдаче сертификационных экзаменов серии Oracle Certified Professional Java Programmer
04.02 DEV-QT10. Прикладное программирование на С++ с использованием Qt. Базовый уровень
11.02 DEV-J60. Технологии разработки корпоративных приложений на платформе Java Enterprise Edition (Java EE)
11.02 DEV-J60. Технологии разработки корпоративных приложений на платформе Java Enterprise Edition (Java EE)
11.03 Введение в тестирование программного обеспечения
11.03 Введение в тестирование программного обеспечения
11.03 Введение в тестирование программного обеспечения
Открыт набор на осенний семестр в Академию информатики для школьников Открыт набор на осенний семестр на программы второго высшего образования
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

EoMPLS + IPSec
liad
#1 Оставлено : 24 августа 2010 г. 17:17:35(UTC)
Ранг: Активный Участник

Группы: Зарегистрированные пользователи
Зарегистрирован: 04.04.2007(UTC)
Сообщений: 111
Баллов: 333
Откуда: Russia St.-Peterburg

Задача такая соединить два офиса на канальном уровне с шифрованием на третьем уровне. Есть два роутера 3845 и 2851. Вариантов соединения думаю тут два EoMPLS+IPSec или L2TP+IPSec.
Выбрал первое. Пока настраиваю EoMPLS но никак не получается.
Роутер 1
Код:

ip cef
!
interface Tunnel0
ip address 10.10.10.1 255.255.255.252
tunnel source GigabitEthernet0/0
tunnel destination 192.168.100.2
tunnel path-mtu-discovery
!
interface GigabitEthernet0/0
ip address 192.168.100.1 255.255.255.252
duplex auto
speed auto
media-type rj45
mpls ip
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1.19
encapsulation dot1Q 119
xconnect 10.10.10.2 119 encapsulation mpls
!
router ospf 100
log-adjacency-changes
network 10.10.10.0 0.0.0.3 area 0
network 192.168.100.0 0.0.0.3 area 0
!
mpls ldp router-id Tunnel0 force

Роутер 2
Код:

ip cef
!
interface Tunnel0
ip address 10.10.10.2 255.255.255.252
tunnel source GigabitEthernet0/0
tunnel destination 192.168.100.1
tunnel path-mtu-discovery
!
interface GigabitEthernet0/0
ip address 192.168.100.2 255.255.255.252
duplex auto
speed auto
media-type rj45
mpls ip
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1.19
encapsulation dot1Q 219
xconnect 10.10.10.1 119 encapsulation mpls
!
router ospf 100
log-adjacency-changes
network 10.10.10.0 0.0.0.3 area 0
network 192.168.100.0 0.0.0.3 area 0
!
mpls ldp router-id Tunnel0 force


тунель работает, а вот узлы подключенные к интерфейсам g0/1 и напрямую и через коммутатор с настроенными vlan 119 и 219 не пингуются.
Потом планирую crypto map привязать к tunnel0 и g0/0.
Реклама
liad
#2 Оставлено : 25 августа 2010 г. 15:07:42(UTC)
Ранг: Активный Участник

Группы: Зарегистрированные пользователи
Зарегистрирован: 04.04.2007(UTC)
Сообщений: 111
Баллов: 333
Откуда: Russia St.-Peterburg

вывод debug xconnect ...
MPLS peer 10.10.10.1, vcid 119, VC UP, VC state UP
XC L2TP: Failed to find session for peer 10.10.10.1, vcid 119
и аналогично на другом
не понятно почему L2TP?
добавлял pw-class
pseudowire-class myclass
encap mpls
interworking ethernet
xconnect 10.10.10.2 119 encapsulation mpls pwclass myclass
все бесполезно
artmar
#3 Оставлено : 25 августа 2010 г. 22:41:13(UTC)
Ранг: Активный Участник

Группы: Зарегистрированные пользователи
Зарегистрирован: 22.10.2003(UTC)
Сообщений: 330
Баллов: 990
Откуда: Russia СПб

1) Заведите лупбеки с маской /32, положите их в ОСПФ
2) туннели и VC с них пускайте
3) повесьте дизайнера/постановщика задачи :)
EoMPLS+GRE+IPSec - это все равно, что лететь самолетом, который перевозится поездом, а он на пароме :В
4) l2tp через GRE, лучшем случае, удастся положить в IPSEC, но тоже будет криво, как задача
5) Зачем это все?

interface GigabitEthernet0/1.19
encapsulation dot1Q <b>119</b>
xconnect 10.10.10.2 119 encapsulation mpls
!
interface GigabitEthernet0/1.19
encapsulation dot1Q <b>219</b>
xconnect 10.10.10.1 119 encapsulation mpls

свич таги правильные расставляет?


Всего хорошего
liad
#4 Оставлено : 26 августа 2010 г. 12:14:51(UTC)
Ранг: Активный Участник

Группы: Зарегистрированные пользователи
Зарегистрирован: 04.04.2007(UTC)
Сообщений: 111
Баллов: 333
Откуда: Russia St.-Peterburg

спасибо, хотя и поздно уже сделал днем ))),
1) лупбеки и туннель в оспф
2) vc - лупбек - тунель кажется так
3) не понял на счет дизайнера/поставщика задачи
именно так Ethernet - MPLS - GRE - IPSec
4) не думаю что l2tp + ipsec быстрее
5) чтобы соединить два офиса на канальном уровне (несколько vlan'ов)

лупбеки я и до этого делал без ipsec'а, но все это у меня заработало когда поставил два коммутатора с одинаковыми vlan'ами и на роутерах сделал
interface GigabitEthernet0/1.19
encapsulation dot1Q 119
xconnect 10.10.20.2 119 encapsulation mpls
!
interface GigabitEthernet0/1.19
encapsulation dot1Q 119
xconnect 10.10.20.1 119 encapsulation mpls

10.10.20.1 и .2 - лупбеки
в общем то, что нужно.
а задача такая: соединить два офиса на канальном уровне, зашифровав канал
switch1 - роутер1 ----------- выделенная линия ------------- роутер2 - switch2
на свитчах несколько vlan'ов
artmar
#5 Оставлено : 26 августа 2010 г. 14:57:46(UTC)
Ранг: Активный Участник

Группы: Зарегистрированные пользователи
Зарегистрирован: 22.10.2003(UTC)
Сообщений: 330
Баллов: 990
Откуда: Russia СПб

<blockquote id="quote"><font size="1" face="Verdana, Helvetica, Arial" id="quote">quote:<hr height="1" noshade id="quote"><i>Originally posted by liad</i>
на свитчах несколько vlan'ов
<hr height="1" noshade id="quote"></blockquote id="quote"></font id="quote">
тогда настрайвайте VC на физическом интерфейсе, вместо тагированных сабов, а порты свичей настройте в транк :)

Грабли вылезут скорее всего несколько позже, когда вы попытаетесь засунуть VC в IPSEC.


Всего хорошего
Всего хорошего
liad
#6 Оставлено : 26 августа 2010 г. 16:02:23(UTC)
Ранг: Активный Участник

Группы: Зарегистрированные пользователи
Зарегистрирован: 04.04.2007(UTC)
Сообщений: 111
Баллов: 333
Откуда: Russia St.-Peterburg

на свитчах и так транки настроены, а на роутере для каждого влана сделал свой саб и свой vc, т.е.
interface GigabitEthernet0/1.19
encapsulation dot1Q 119
xconnect 10.10.10.2 119 encapsulation mpls
!
interface GigabitEthernet0/1.10
encapsulation dot1Q 100
xconnect 10.10.10.1 100 encapsulation mpls
вроде пока все работает и при том скорость не плохая на 10 мбитном канале файл размером 150 мбайт за 2,5 минуты.
RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Guest
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.